Delivery Issue Africell - Angola
Incident Report for Sinch
Resolved
This incident has been resolved

Incident Start Time: 2024-05-30 11:31 UTC

Incident End Time: 2024-05-30 11:55 UTC
Posted May 30, 2024 - 17:05 UTC
Update
We are continuing to investigate this issue.
Posted May 30, 2024 - 13:20 UTC
Investigating
We are currently observing delivery issues towards Africell - Angola

Incident Start Time: 2024-05-30 11:31 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 30, 2024 - 11:49 UTC
This incident affected: Connectivity by region (SMS - EMEA).