Delivery Issue Mexico - Izzi
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-05-19 22:30 UTC
Incident End Time: 2023-05-19 23:33 UTC
Posted May 20, 2023 - 03:15 UTC
Update
We are continuing to investigate this issue.
Posted May 20, 2023 - 00:36 UTC
Investigating
We are currently observing delivery issues towards Mexico - Izzi.

Incident Start Time: 2023-05-19 22:30 UTC

We will update as soon as we have more information.
Posted May 19, 2023 - 23:23 UTC
This incident affected: Connectivity by region (SMS - Latin America).