Delivery Issue Congo (DRC) - Africell
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2024-05-10 20:32 UTC

Incident End Time: 2024-05-11 03:28 UTC
Posted May 11, 2024 - 15:39 UTC
Update
We are continuing to investigate this issue.
Posted May 11, 2024 - 07:05 UTC
Update
We are continuing to investigate this issue.
Posted May 11, 2024 - 02:07 UTC
Update
We are continuing to investigate this issue.
Posted May 10, 2024 - 22:02 UTC
Investigating
We are currently observing delivery issues towards Congo (DRC) - Africell

Incident Start Time: 2024-05-10 20:32 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 10, 2024 - 20:44 UTC
This incident affected: Connectivity by region (SMS - EMEA).