Delivery Issue - Italy

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-02-27 08:03 UTC
Incident End Time: 2025-02-27 11:40 UTC
Posted Feb 27, 2025 - 12:32 UTC

Update

We are continuing to investigate this issue.
Posted Feb 27, 2025 - 10:01 UTC

Investigating

We are currently observing delivery issues in Italy.

Incident Start Time: 2025-02-27 08:03 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Feb 27, 2025 - 08:49 UTC
This incident affected: External Connectivity (SMS - EMEA).