Delivery Issue Netherlands - Odido.
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2024-09-02 17:24 UTC
Incident End Time: 2024-09-02 20:18 UTC
Posted Sep 02, 2024 - 21:54 UTC
Investigating
We are currently observing delivery issues in Netherlands - Odido.

Incident Start Time: 2024-09-02 17:24 UTC

We will update as soon as we have more information.
Posted Sep 02, 2024 - 19:12 UTC
This incident affected: Connectivity by region (SMS - EMEA).