Delivery Issue Mexico - Izzi
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-05-23 21:14 UTC
Incident End Time: 2023-05-24 03:30 UTC
Posted May 24, 2023 - 03:45 UTC
Investigating
We are currently observing delivery issues towards Mexico - Izzi.

Incident Start Time: 2023-05-23 21:14 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 23, 2023 - 22:45 UTC
This incident affected: Sinch DI Services (SMS 365 Enterprise) and Connectivity by region (SMS - Latin America).