Service Disruption
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 24, 2017 - 15:06 GMT-01:00
Investigating
We are currently experiencing service quality issues in some parts of our system.

This is being investigated with a matter of urgency and we hope to resolve this shortly.
Posted almost 2 years ago. Nov 24, 2017 - 14:07 GMT-01:00