Sinch Engage - Platform Degradation

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-08-06 13:46 UTC
Incident End Time: 2026-08-06 18:19 UTC
Posted Aug 06, 2026 - 18:28 UTC

Investigating

We are writing to inform you that we are experiencing a service degradation impacting the Sinch Engage platform.

Impact: Customers may experience that some sections of the Sinch Engage dashboard are currently degraded.

Incident Start Time: 2026-08-06 13:46 UTC

We are actively investigating and will provide further updates as more information becomes available.
Posted Aug 06, 2026 - 17:07 UTC
This incident affected: Sinch Engage (Web Portal).