Service Notification - Dashboard
Incident Report for Sinch
Resolved
We are writing to inform you that this incident resolved.

End Time: 2021-04-06 08:51 UTC

We apologize for any inconvenience this may cause you and if you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Apr 06, 2021 - 09:02 UTC
Investigating
Dear Client,

We are writing to inform you that we are currently experiencing an issue processing payments on our Customer Portal, dashboard.sinch.com.

Start Time: 2021-04-06 07:52 UTC

Our engineers are working to restore service as soon as possible.

We apologize for any inconvenience this may cause you and if you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Apr 06, 2021 - 08:33 UTC
This incident affected: Customer Portal (Payment).