Incident Start Time: 2026-03-24 13:01 UTC Incident End Time: 2026-03-24 19:40 UTC
Posted Mar 24, 2026 - 18:49 UTC
Update
We are continuing to investigate this issue.
Posted Mar 24, 2026 - 18:07 UTC
Investigating
Dear client,
We are currently experiencing a service disruption impacting parts of the Sinch Engage platform in the EMEA region, specifically affecting integrations with Salesforce, HubSpot, and Zoho CRM.
Impact: Some customers may experience issues sending SMS via these integrations Our teams are actively investigating and working to restore full service as quickly as possible.
Incident Start Time: 2026-03-24 13:01 UTC
Our teams are actively investigating and working to restore full service as quickly as possible.
We will update as soon as we have more information. If you have any questions, please contact support@sinch.com.
Posted Mar 24, 2026 - 16:51 UTC
This incident affected: Sinch Engage Integrations (Hubspot, Zoho CRM, Salesforce).