Delivery Issue United Kingdom - 3

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-02-20 16:41 UTC
Incident End Time: 2026-02-21 03:55 UTC
Posted Feb 21, 2026 - 05:18 UTC

Update

We are continuing to investigate this issue.
Posted Feb 21, 2026 - 01:20 UTC

Update

We are continuing to investigate this issue.
Posted Feb 20, 2026 - 23:18 UTC

Investigating

We are writing to inform you that we are currently observing delivery issues towards United Kingdom - 3.

Incident Start Time: 2026-02-20 16:41 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts.
Posted Feb 20, 2026 - 22:06 UTC
This incident affected: External Connectivity (SMS - EMEA).