Service Disruption - Sinch Engage - Social Campaigns Creation Failure

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-04-17 08:00 UTC
Incident End Time: 2026-04-17 12:20 UTC
Posted Apr 17, 2026 - 17:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 12:06 UTC

Update

We are continuing to investigate this issue.
Posted Apr 17, 2026 - 11:08 UTC

Investigating

We are currently investigating an issue affecting Sinch Engage Social Campaigns where users may be unable to create new campaigns from the Social Messaging - All Campaigns section.

Impact: Clicking the Create button may result in no action, and campaign creation is currently impacted.

We will provide further updates as more information becomes available.
Posted Apr 17, 2026 - 09:30 UTC
This incident affected: Sinch Engage (The Hub).