Sinch support number - Incoming call issues
Incident Report for Sinch
Resolved
Dear Client,

This incident has been resolved.

If you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Oct 10, 2021 - 22:07 UTC
Investigating
Dear Client,

We are currently experiencing issues with incoming calls to our support number.

Impact: Incoming calls to Sinch Support may not be answered.

We are investigating this issue and will update you as soon there is more information available.

If you have any further questions or concerns please do not hesitate to reach out to support@sinch.com
Posted Oct 10, 2021 - 21:17 UTC
This incident affected: Customer Portal (Customer Support).