Sinch Engage - platform Degradation

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-06-03 20:15 UTC
Incident End Time: 2026.06.03 23:16 UTC
Posted Jun 03, 2026 - 23:33 UTC

Investigating

We are writing to inform you that we are experiencing a service degradation impacting the Sinch Engage platform. New Message Screen Unavailable.

Impact: New Message Screen is currently degraded.

Incident Start Time: 2026-06-03 20:30 UTC

We are actively investigating and will provide further updates as more information becomes available.
Posted Jun 03, 2026 - 21:23 UTC
This incident affected: Sinch Engage (The Hub).