Service Degradation - Customer Dashboard
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 06:54 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 05, 2024 - 13:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 05, 2024 - 09:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 05, 2024 - 09:12 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 04, 2024 - 22:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 04, 2024 - 17:07 UTC
Identified
We have identified that the issue occurs when using browsers that have disabled third party cookies.

Switching to a browser that doesn't disable third party cookies for the first login will stop the issue on subsequent logins to Dashboard from any browser.

Our engineers are working on a fix and we will update as soon as we have more information.
Posted Jun 04, 2024 - 14:06 UTC
Investigating
We are writing to inform you that we are currently facing a service degradation on the customer dashboard, Dashboard.sinch.com.

Impact: Customers may not be able to login to their accounts, or be disconnected while browsing dashboard.sinch.com

Our engineers are working to restore service as soon as possible.
Posted Jun 04, 2024 - 11:55 UTC
This incident affected: Customer Portal (Payment, SMS Administration, Numbers Administration, Analytics, Customer Support, 2FA, US Campaigns, Login/Sign up).