Delivery Issue United Kingdom - Lycamobile
Incident Report for Sinch
Resolved
This incident has now been resolved.

Incident End Time: 2024-07-18 01:12 UTC
Posted Jul 18, 2024 - 04:35 UTC
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 00:00 UTC
Investigating
We are currently observing delivery issues to United Kingdom - Lycamobile.

Incident Start Time: 2024-07-17 21:15 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Jul 17, 2024 - 22:50 UTC
This incident affected: Connectivity by region (SMS - EMEA).