Delivery Issue Angola - Africell

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-03-31 15:23 UTC
Incident End Time: 2025-03-31 17:06 UTC
Posted Mar 31, 2025 - 18:10 UTC

Investigating

We are currently observing delivery issues in Angola - Africell.

Incident Start Time: 2025-03-31 15:23 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Mar 31, 2025 - 16:11 UTC
This incident affected: External Connectivity (SMS - EMEA).