Sinch Engage - Degradation

Incident Report for Sinch

Resolved

This incident has been resolved.

Start Time : 2025-11-07 07:00 UTC

End Time : 2025-11-07 13:37 UTC
Posted Nov 07, 2025 - 14:25 UTC

Investigating

Dear client,

We are writing to inform you that we are experiencing a temporary service disruption impacting the Sinch Engage platform.
Some customers may encounter issues when trying to access the WhatsApp channel in the Hub.
Clicking on “See details” under the WhatsApp channel might result in 404 HTTP error.

https://eu.app.sinch.com/
https://hub.messagemedia.com/

We are currently working on resolving the issue.

Start Time (UTC): 2025-11-07 07:00 UTC

We apologize for the inconvenience and appreciate your patience while we are working to resolve the issue.
Posted Nov 07, 2025 - 12:46 UTC
This incident affected: Sinch Engage (The Hub).