Delivery Issue Nicaragua - Tigo

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-05-08 05:37 UTC
Incident End Time: 2025-05-08 09:13 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts
Posted May 08, 2025 - 12:21 UTC

Monitoring

Performance has been restored.
We will continue to monitor and update the status accordingly.
Posted May 08, 2025 - 08:20 UTC

Investigating

We are currently observing delivery issues in Nicaragua - Tigo

Incident Start Time: 2025-05-08 05:37 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 08, 2025 - 05:57 UTC
This incident affected: External Connectivity (SMS - LATAM).