Delivery Issue Mexico - Izzy
Incident Report for Sinch
Resolved
This incident has been resolved

Incident Start Time: 2024-06-10 03:05 UTC
Incident End Time: 2024-06-10 04:09 UTC
Posted Jun 10, 2024 - 04:47 UTC
Investigating
We are currently observing delivery issues towards Mexico - Izzy.


Incident Start Time: 2024-06-10 03:05 UTC

Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Jun 10, 2024 - 03:36 UTC
This incident affected: Connectivity by region (SMS - Latin America).