Sinch Engage - Degradation

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-10-15 14:14 UTC
Incident End Time: 2025-10-15 17:20 UTC
Posted Oct 15, 2025 - 19:13 UTC

Monitoring

A fix has been implemented, we will continue to monitor for any further issues.
Posted Oct 15, 2025 - 17:30 UTC

Investigating

We are currently investigating an issue with logging in to Sinch Engage.

Incident Start Time: 2025-10-15 14:14 UTC

Impact: Clients may experience issues logging in to the Sinch Engage application.
Posted Oct 15, 2025 - 16:35 UTC
This incident affected: Sinch Engage (The Hub).