Delivery Issue Mexico - Izzi
Incident Report for Sinch
Resolved
This incident has been resolved.

Incident Start Time: 2023-06-02 01:35 UTC
Incident End Time: 2023-06-02 02:58 UTC
Posted Jun 02, 2023 - 04:01 UTC
Investigating
We are currently observing delivery issues towards Mexico - Izzi.

Incident Start Time: 2023-06-02 01:35 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted Jun 02, 2023 - 02:49 UTC
This incident affected: Connectivity by region (SMS - Latin America).