Delivery Issue Brazil - Telecall

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-05-09 14:13 UTC
Incident Start Time: 2025-05-09 19:07 UTC
Posted May 09, 2025 - 20:02 UTC

Update

We are continuing to investigate this issue.
Posted May 09, 2025 - 16:23 UTC

Investigating

We are currently observing delivery issues in Brazil - Telecall

Incident Start Time: 2025-05-09 14:13 UTC
Impact: Delayed MT's/Delayed MO's/Missing delivery receipts/Late delivery receipts

We will update as soon as we have more information.
Posted May 09, 2025 - 15:15 UTC
This incident affected: External Connectivity (SMS - LATAM).