Service Degradation - Customer Dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident start time: 2026-08-26 20:32 UTC
Incident end time: 2026-08-27 05:09 UTC
Posted Aug 27, 2026 - 11:05 UTC

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 07:05 UTC

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 03:04 UTC

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 00:12 UTC

Investigating

We are currently facing a service degradation on the customer dashboard, Dashboard.sinch.com.

Impact: Analytics is currently degraded in the US region.

Our engineering team is working to restore full functionality as soon as possible.

For any inquiries, please contact support@sinch.com.
Posted Aug 26, 2026 - 22:47 UTC
This incident affected: Dashboard.sinch.com (Analytics).