Service degradation - Analytics on customer dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start time: 11:57 UTC 2025-05-14
Incident End time: 14:35 UTC 2025-05-14
Posted May 14, 2025 - 15:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 12:13 UTC

Investigating

Dear Client,

We are writing to inform you that we are currently facing a service degradation for Analytics on the customer dashboard.

Impact: Delayed balance updates and data in Message Search and Analytics on dashboard.sinch.com

Our engineers are working to restore service as soon as possible.

We appreciate your patience and apologize for any inconvenience during this period.

Please contact support@sinch.com should you require further information or assistance.
Posted May 14, 2025 - 11:57 UTC
This incident affected: Dashboard.sinch.com (Analytics).