Customer Support - Ticketing System

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2026-04-21 14:39 UTC
Incident End Time: 2026-04-21 15:29 UTC
Posted Apr 21, 2026 - 17:19 UTC

Investigating

We are currently experiencing an issue with our ticketing system related to the following emails:

support@sinch.com

Impact: Customers may experience delayed responses from support.

As an alternative in the meantime, please raise all tickets via our ticketing portal at support.sinch.com.
Posted Apr 21, 2026 - 15:11 UTC
This incident affected: Dashboard.sinch.com (Customer Support).