Service Degradation - Customer Dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-11-05 17:10 UTC
Incident End Time: 2025-11-06 03:14 UTC
Posted Nov 06, 2025 - 04:16 UTC

Investigating

We are writing to inform you that we are currently facing a service degradation on the customer dashboard, Dashboard.sinch.com.

Impact: Analytics and Numbers Administration is degraded.

We will provide ongoing updates on this page.
Posted Nov 06, 2025 - 01:16 UTC
This incident affected: Dashboard.sinch.com (Numbers Administration, Analytics).