Service Degradation - Customer Dashboard

Incident Report for Sinch

Resolved

This incident has been resolved.

Start Time: 2026-02-03 14:50 UTC
End Time: 2026-02-03 16:12 UTC
Posted Feb 03, 2026 - 20:24 UTC

Monitoring

We can observe that functionality has been restored.

Start Time: 2026-02-03 14:50 UTC
Restored time: 2026-02-03 16:12 UTC

We will continue to monitor for any further issues.
Posted Feb 03, 2026 - 16:29 UTC

Investigating

We are currently facing a service degradation on the customer dashboard, Dashboard.sinch.com.

Start Time: 2026-02-03, 14:50 UTC

Impact: Numbers Administration, SMS Administration, and Analytics is currently degraded.

Our engineering team is working to restore full functionality as soon as possible.

For any inquiries, please contact support@sinch.com.
Posted Feb 03, 2026 - 15:36 UTC
This incident affected: Dashboard.sinch.com (SMS Administration, Numbers Administration, Analytics).