US/CA Sites - Number Lookup degradation

Incident Report for Sinch

Resolved

This incident has been resolved.

Incident Start Time: 2025-10-05 02:20 UTC

Incident End Time: 2025-10-05 10:57 UTC
Posted Oct 05, 2025 - 12:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2025 - 10:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 05, 2025 - 10:09 UTC

Update

We are continuing to investigate this issue.
Posted Oct 05, 2025 - 08:00 UTC

Investigating

We are currently experiencing a performance degradation on our CA and US sites.

Incident Start Time: 2025-10-05 02:20 UTC

Impact: Failed or Delayed MT's/Late delivery receipts

We will update as soon as we have more information.
Posted Oct 05, 2025 - 06:47 UTC
This incident affected: External Connectivity (SMS - APAC, SMS - EMEA, SMS - LATAM, SMS - CA - ShortCode, SMS - CA - Toll Free, SMS - US - ShortCode, SMS - US - Toll Free, SMS - US - 10DLC) and Lookup API Endpoints (ENUM US, HTTP US, ENUM CA, HTTP CA).