Sinch Portal Email Issues
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted 29 days ago. Sep 25, 2017 - 09:17 CEST
Identified
We are currently experiencing issues with one of our email providers. During this time you may find emails that you should normally receive from the Sinch Portal not arriving as expected.

This includes Billing and account related emails.
Posted about 1 month ago. Sep 18, 2017 - 17:57 CEST