Dashboard Analytics Maintenance
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 18, 2017 - 15:51 CEST
Identified
We are currently undergoing some unplanned maintenance in the Sinch portal.

You may experience inaccurate graphs during this time, we are working on restoring them as quickly as possible.

Apologies for any inconvenience caused
Posted about 1 month ago. Sep 15, 2017 - 16:52 CEST