Calling Issue
Incident Report for Sinch
Resolved
All issues have been resolved. All systems are functional.
Posted almost 3 years ago. Jan 05, 2015 - 00:46 CET
Investigating
We are currently investigating degraded performance and will update here as we have more information.
Posted almost 3 years ago. Jan 05, 2015 - 00:41 CET